OmniRig

OmniRig v2.1 with new Features

OmniRig v2.1 with new Features

I’m pleased to offer you my new ominiRig v2.1 development with the following new features:
- Supports now up to four RIGs
- You can name the tabs of your RIGs with your own text
- The minimum polling interval is now 20ms instead of 100ms
- The GUI of the main Window is bigger to see all your four RIG-Tabs

What is OmniRig v2.1?
More than one program can you control the transceiver via OmniRig at the same time. In a typical scenario, the user will have a logger (e.g. Swisslog), a SDR receiver as panadapter (e.g. SDRPlay with SDR Radio v3.x), a remote SDR Receiver such as ColibriDDC (e.g. ExpertSDR2 Client software), and a digital mode software for FT8 (e.g. WSJT-X) running on his system. All these programs will know the current frequency, mode and all other rig parameters, and will be able to change them. The only requirement is that all programs use the OmniRig v2.1 component. Programs that use their own code to control the rig, require exclusive access to the communications port, and are incompatible with OmniRig v2.1. OmniRig v2.1 can control up to four transceivers or receivers if they are connected to different COM ports. Rig types are not hard-coded in OmniRig v2.1. On start-up, the component reads the rig description files from the Rigs\ sub-directory and supports all rigs for which a command set is defined. If your rig is not supported yet, create your own rig description file (and share it with other Omni-Rig users).

Development
OmniRig v2.1 update is for free - developed by Stephan Andratsch, sponsored by HB9RYZ
Thanks to Alex Shovkoplyas (VE3NEA), who developed the first OminRig Version.

Main features of the new OmniRig v2.1
- Supports now up to four RIGs
- You can name the tabs of your RIGs with your own text
- The minimum polling interval is now 20ms instead of 100ms
- The GUI of the main Window is bigger to see all your four RIG-Tabs
- will be supported from the new Swisslog version 5.99e (Dec. 2019)

Important to know - The new Omnirig v2.1 is not compatible with Omnirig v1.19! The new Omnirig v2.1 only runs with programs that have been developed for it, e.g. Swisslog v5.99e (Dec. 2019). However, Omnirig v1.19 and Omnirig v2.1 can run on the same computer at the same time.

Supported Transceivers/Receivers ...
Download the latest RIG-Ini Files (November 2019) here [150 KB]

ICOM IC-9700 INI-File for Omnirig
Download [7 KB] the IC-9700 INI-File

  • FlexRadio Systems such as FLEX 6300, 6500, 6700, 6400M, 6600M, etc. please use for all Flex radios the RIG-File SmartSDR
  • TS-440, TS-480, TS-570, TS-590, TS-690, TS-850, TS-870, TS-930, TS-2000, all other Kenwoods
  • FT-100D, FT-450, FT-747, FT-757, FT-817, FT-840, FT-847, FT-857, FT-897, FT-900, FT-920, FT-950, FT-990, FT-991, FT-1000, FT-1000MP, FT-2000, FT-9000, FTDX-3000, FT-DX5000MP
  • IC-78, IC-275H, IC-703, IC-706MKII, IC-706MKiiG, IC-718, IC-725, IC-726, IC-728, IC-735, IC-737, IC-738, IC-746, IC-746Pro, IC-751,IC-756, IC-756Pro, IC-756ProII, IC-756ProIII, IC-761, IC-765, IC-775, IC-781, IC-821, IC-910, IC-970D, IC-7000, IC-7100, IC-7200, IC-7300, IC-7315, IC-7410, IC-7600, IC-7610, IC-7700, IC-7800, IC-7850, IC-7851, IC-9100, IC-R75, IC-R8500, IC-R9000, IC-M70
  • CODAN, Elecraft K2, Elecraft K3, Ten-Tec Eagle, Ten-Tec Paragon II, Ten-Tec Orion, Ten-Tec Jupiter, Ten-Tec Omni VI+, Ten-Tec Omni VII, TenTec RX-350, JST-245, DX-77, NRD-535(DG), PowerSDR, Perseus, FRG-100, ZS-1, Elad-FDMSW2, ADT-200A, AOR AR5000, AOR AR8600

OmniRig v2.1